Tripbuilder Service Disruption
Incident Report for Nezasa
Resolved
The issue has been resolved and all our services are back up and running.

Over the weekend the queue of background jobs filled up. This was caused by a faulty hotel importer. We were able to clean up the queue this morning, but still had many legit tasks to execute. Therefore it took a bit longer to catch up.

We're now seeing recently scheduled jobs start at once, and also itineraries immediately show up in customer care. We will follow up with a postmortem to ensure we fully understand how this happened and how we could improve our process and monitoring further.


We apologize for any inconvenience this may have caused.

Should you want any further details, feel free to contact us anytime.

Sincerely,
The Nezasa Operations Team
Posted Feb 12, 2024 - 13:43 UTC
Update
Thing are slowly getting better and workload of TripBuilder returns to normal state. We still have a backlog of itineraries created since yesterday which do not yet show up in customer care. We expect them to show up in the next 1 to 2 hours.

We keep continue monitoring the situation.
Posted Feb 12, 2024 - 11:29 UTC
Update
We identified the problem causing the high workload and were able to clear the faulty tasks.

TripBuilder is now catching up with the backlog of pending tasks, we are further investigating how long it will take to catch up.

We will provide a next update in 1 hours.
Posted Feb 12, 2024 - 10:26 UTC
Update
We are continuing to investigate this issue.
Posted Feb 12, 2024 - 10:22 UTC
Investigating
We are currently experiencing a service disruption.

Our team is working to identify the cause and implement a solution as quickly as possible. TripBuilder users may be affected as follows by this issue:

- We noticed a higher than usual workload on background tasks
- Things like reports or also itineraries showing up in customer care might be delayed
- Booking and checkout seems not affected

We will send you an additional update shortly.

Sincerely,
The Nezasa Operations Team
Posted Feb 12, 2024 - 08:37 UTC
This incident affected: TripBuilder.